webStore configuration - maybe lama's question...

Aug 30, 2011 at 3:12 PM

Hi,

I tried your webstore, in tutorials it looks very good, so I wanted to try it. I have problem with webStore configuration... And I didn't found anything...

Where can I find this webStore configuration or how this file looks "inside" - what have to be there ? Have I make it by myself?

 

Thanks!

yours beginner lama.... :))

Coordinator
Aug 30, 2011 at 8:49 PM

Hi,

Thank you for your message. We need a bit more info. to clearly understand the problem. What version did you try , V0.2 ?
Did you encounter a problem to deploy WebStore or to access the management console? Do you have an error message ?
We know that we need to create a real documentation to help install configure and run a WebStore instance and we will be working on it soon!
Provide us with more info and we will be happy to help.
Best regards,

 

Aug 31, 2011 at 8:31 AM
Edited Aug 31, 2011 at 10:53 AM

Hi yaligault,

I am sorry that my last post is not specific (I was very tired from work, and maybe I think about one thing and write other thing :D)

I'm using latest version (0.2), installed via Gallery in Orchard CMS...

Did you encounter a problem to deploy WebStore or to access the management console? // My problem is with configuration. Install is OK, everything what is in video I have there. But I don't know, what or where is "webstore configuration", in Main settings is input for ServicesPath - in video url address looks like http://some_IP_address/ServicesOrchard/ ( That I found here ) - Don't know where I have to looking for to find this folder/file or if I have to make new one by myself. When I tried some URLs on server (something like http://my_server_IP/wwwroot/my_orchard_folder/Some_services_folder and so on) I get only that is Unable to connect WebServices

Don't know if screen helps but... I mean this: Screenshot

access to management console - I haven' because I have not the webstore configuration (WebServices in settings), so I stop after installation, cannot synchronize.

Hmm.. And I look now one more and... I think that I am looking for this configuration I will try it today - edit - nothing change... I look at the video of installing this module and... Is it possible that the orchard installing didn't install all what this module need?

And I want to ask you where will be this Management? I am looking forward to :)

 

Thanks

 (Sorry about my English....)

Coordinator
Aug 31, 2011 at 9:51 PM

Hi,

What happens is that your are trying to install WebStore v0.2 and the Orchard module available in the Orchard Gallery. This module was designed for webstore V0.1 and it is not compatible with Magelia WebStore V0.2.
I suggest that you simply set up WebSTore v0.1 which is still available on Codeplex and the Orchard module and installation should work just fine.

We will upgrade the Orchard module to make it compatible with WebStore v0.3 but at this time we have to keep working on WebStore to be able to release a V1 in Q4 2011.

As already mentionned WebStore V0.1 and V0.2 are not fr production environment at this time because these are only pre-versions.

best regards,

 

Aug 31, 2011 at 10:41 PM

So, I have to uninstal v0.2 and install older version that should be function? - Will I need some config file in settings like it was on my screenshot? Or this will be function of v0.2 ?

Tommorow I will try it, thanks!

 

Gollumek

Sep 1, 2011 at 11:50 AM
Edited Sep 1, 2011 at 1:00 PM

Hi,

so, I installed module via IIS manager and now it looks promisse :)), some errors made by missing mvc3 on server... So, now I have problem with connection string in web.config file...

I have webserver with MSSQL (not sqlexpress).

<connectionStrings>
 <add name="GenericObsoleteEntities" connectionString="metadata=res://*/Obsolete.Data.Models.GenericModel.csdl|res://*/Obsolete.Data.Models.GenericModel.ssdl|res://*/Obsolete.Data.Models.GenericModel.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=.\SQLExpress;Initial Catalog=Magelia_WebStore;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
 <add name="GenericEntities" connectionString="metadata=res://*/Data.Models.GenericModel.csdl|res://*/Data.Models.GenericModel.ssdl|res://*/Data.Models.GenericModel.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=.\SQLExpress;Initial Catalog=Magelia_WebStore;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
 <add name="WebStoreEntities" connectionString="metadata=res://*/Models.WebStoreModel.csdl|res://*/Models.WebStoreModel.ssdl|res://*/Models.WebStoreModel.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=.\SQLExpress;Initial Catalog=Magelia_WebStore;Integrated Security=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
 <add name="MageliaWebStore" providerName="SQL" connectionString="Data Source=.\SQLExpress;Initial Catalog=Magelia_WebStore;Integrated Security=True" />
</connectionStrings>

 

there is some problem. I add my "User ID=Some_User_Id;Password=Some_Password" into each connectionString
.\SQLExpress I replace by (local)

Catalog is db name (Magelia_WebStore) uuuuf what should I do? this is not working :( when I save this file and want to look on http://my_page.com/extranet I get nothing. Page is loading and loading and loading... What's wrong?

Coordinator
Sep 1, 2011 at 3:14 PM

Hello Gollumek,

Thanks for trying our products.

When you say that the page is loading, if you wait some time there is no error ? If the problem came from SQLConnection, you should have a timeout error.

Does your IIS server function properly ? Is there any website working ? if you add a file (test.txt for example) on the root folder of the website and go to http://my_page.com/extranet/, is the file displayed ?

Which type of IIS are you using ? IIS6, IIS7, IIS7.5 ? is it a dedicated hosting or a shared one ?

Do you have any error on the window eventlog ?

Thanks,

Cyril DURAND

 

Sep 1, 2011 at 3:58 PM

Hi cdurand,

on we have IIS7.5, on server we have a lot of websites, every website has own folder. All webs works fine. In eventlog is no event for this test "instance" :( When the page loading I didn't get no timeout error, because all of time it loading... No view, nothing :(

I tried http://my_website.com/extranet/default.aspx and this redirected to .com/extranet/Authetification.aspx?and_some_string but about this page I get only error 404 - strange :((

 

So I deleted all what folder extranet included and upload this folder again. Now, I get error that I have no permissions to write into temporary in windows/framework/temporary (or something like that).

Last error after rewriting includes of folder extranet is this:

Server Error in '/extranet' Application.
Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0016: Could not write to output file 'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\extranet\c60a2646\8646a1b8\en-US\App_GlobalResources.uahqtz8h.resources.dll' -- 'Access is denied. '

Source Error:


[No relevant source lines]


Source File: Line: 0

This error is strange too, because I have made this instance under admin permisinions....

 

Gollumek

 

 

Coordinator
Sep 1, 2011 at 9:09 PM

Hi,

We had quite a few downloads and installs and no one reported such problems. Sooy about that but It is not easy for us to understand and help, since the errors you get seems to be permission issues. The best thing would probably be try to simply install the solution and IIS etc. alone on a dedicated VM or server.  We also really suggest that you wait for a new version of WebStore and of the Orchard module for WebStore because there is a real gap between WebStore v0.1 and v0.2 and we will keep doing some changes in V0.2 that will be structural and it might be difficult to upgrade.

Sep 2, 2011 at 8:57 AM

hi,

I am sure, that mistake is on my site, but I don't know where :(( I proceeded as follows:

Setting IIS, install

  1. IIS 7.5 - import pack of v0.1 - everything passed fine, in my web there are orchard folders and four applications of Magelia webstore (extranet, services, www, medias)
  2. In application pools I selected my website and select Advanced settings and change from Local System to Network services (because there is no Integrated ASP.NET as it is in documentation - maybe can mistake here????)

Setting sql

  1. SQL server (MS SQL server 2008 R2)- I created new database, named Magelia_WebStore, set initial size to 3MB because if I change to 2MB server told me that is a few and minimum is 3, but don't think that this is the mistake.., then save
  2. Add script to this database and execute it, all were created successfully 
  3. In user NETWORK SERVICE I set that magelia_webstore is mapped to this login, and membership is magelia_user (and public too). I tried this, but we have own user for this web in db. So If I made a same operation with our user (it has all needed permissions) - set that magelia_webstore is mapped to ourUser login and membership is magelia_user, I thought that it is same as with Network service "user"... -- Maybe mistake here....????? then I click OK.

Editing configuration files

  1. Then I go into folder in c:\inetpub\wwwroot\myfolderWithWeb\services and open Web.Config, there I edit some pathes to folders there are in webfolder on server, and change connectionString - set database name, User ID=ourUser; Password=OurPassword; (only when I use our user not network service, password and user are ok, no mistake in), and save
  2. In \extranet folder I edited web.config - edited pathes to services, and path to media and extensions.... That was in documentation....

Now it is in stage that when I go to http://test2.hotovo.info/extranet I can wait a long time, because there is something for loading (as I wrote earlier). When I go to address http://test2.hotovo.info/extranet/default.aspx I am redirected to this: http://test2.hotovo.info/extranet/Authentication.aspx?ReturnUrl=%2fextranet%2fdefault.aspx and I get error page with:

Server Error in '/extranet' Application.
The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly. 
Requested URL: /extranet/Authentication.aspx
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.237 

don't understand, file Authentication.aspx exist... No event in event log, no event in log of this web..

So, where could I make mistake? I am sorry that I bother with this... but I don't understand why it doesn't work :( Could there be problem only with permissions? or is there something that I have to install into server?

Thanks... :)

Gollumek

Coordinator
Sep 2, 2011 at 9:54 AM

Hello,

Really strange, everything looks OK.

Did you configure the IIS website correctly ? Did you create 3 application on the IIS website ? The 3 picture of this page show how the IIS website must be configured : http://mageliawebstore.codeplex.com/wikipage?title=setting-up-iis

Could you try on another IIS server ? maybe on your local machine ?

As yal said, there is a big gap between 0.1 and 0.2, in future versions we will add setup which will do almost everything for you.

Thanks,

Cyril DURAND

Sep 2, 2011 at 10:02 AM
Edited Sep 2, 2011 at 10:17 AM

Hi cdurand,

i set IIS same like is on documentation that you send me... Yes, I have there 4 application. I cannot try it on another IIS server... On local machine I tried but there I couldn't run script for database... And in local IIS on comp I haven't choice "Deploy.." and "Import" so, I cannot try it :((

 As yal said, there is a big gap between 0.1 and 0.2/// yes, I read it, this what I am trying to run is 0.1, but now I go to try 0.2 because last time I didn't know how to install it, but now I know :)) so I go to try v 0.2 of webstore, and give you "report" if it will be ok or not.... It is last chance :D Because when I can to write my own eshop, that will be a looooong time, because I am absolute beginner in asp.net mvc.... :))

 

Gollumek

Dec 16, 2011 at 9:31 AM

Hello! I have some troubles with WebStore module. I've installed it from the orchard gallery from the dashboard of the site.

First at all I can't undestand which ServicesPath I have to insert, it says: "unable to connect to web service".

Now I have module version 0.2 and Orchard version 1.3.0.0. Are they compatible? I saw that a new module version has been released but it is not available from the gallery. Can I download it from project page and install from the dashboard? How can I do that?

Secondly I noticed that when I install the WebStore, I can't work with the content becouse it shows me the following error message:      "

The best overloaded method match for 'string.ToString(System.IFormatProvider)' has some invalid arguments

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Microsoft.CSharp.RuntimeBinder.RuntimeBinderException: The best overloaded method match for 'string.ToString(System.IFormatProvider)' has some invalid arguments

Source Error:

Line 1:  <div class="Product_Price">
Line 2:  @T("Price: ") @Model.Price.ToString(".00") @Model.Currency
Line 3:  </div>

"      

 

How can I fix this error?

Thank you very much for your help.            

Coordinator
Dec 16, 2011 at 4:42 PM

Hello,

Please note that the orchard module is at this time only compatible with Magelia WebStore v0.1. We are doing our best to provide an updated version of the Orchard module as soon as possible, we are currently focus on the Magelia WebStore 1.0 version.

Thanks,

Feb 6, 2012 at 11:33 AM

 


I have an issue , When i try to configure WebStore e-commerce like in http://mageliawebstore.codeplex.com/wikipage?title=Adding-and-configuring-the-WebStore-e-commerce-module-for-Orchard  the service path is not working http://188.165.251.144/ServicesOrchard/ so i can't complete the configuration ,

 

Could you help me ?