problem with Magelia.WebStore.2.3.263.startersite.VS2012

Mar 14, 2013 at 9:05 AM
Edited Mar 14, 2013 at 9:06 AM
Attempting to run Magelia.WebStore.2.3.263.startersite.VS2012 in my Vs2k12, I get a null reference error in

public abstract class WebStoreContextBase : WebStoreContext<CatalogServiceClient>

on this line

hubs.Reset(DependencyResolver.Instance.Resolve<WebStoreContextSettings>());

Can anybody explain what the problem is? How to run Magelia.WebStore.2.3.263.startersite.VS2012 in VisualStudio?
Coordinator
Mar 14, 2013 at 10:13 AM
Hi jambro,

It seems that there is an error on Web Platform Installer :-(.
Despite the fact that the version displayed on WebPI is 2.3.263.3, the URL link to the 2.2.215.3 version. The 2.3.263 version of the startersite doesn't work with the 2.2.215.3 version of the administration console.

We are working with the WebPI team to correct the URL.

In order to correct the issue, you will have to manually install the administration console. See http://www.magelia.org/resources/guides/installation-guide#Alternate%20Installation%20Mode:%20Installation%20with%20WebDeploy%20-%20Advanced%20Solution for more information.

Feel free to ask if you any other question.

Thanks,

Cyril DURAND
Mar 14, 2013 at 3:26 PM
Edited Mar 14, 2013 at 3:30 PM
Well, I'm not sure I want to go through the entire exercise of installing things in IIS. I only want to run the thing in my Vs2k12.

I qualify my problem. If I attempt to run the StarterSite as is in my Vs2k12, my browser keeps spinning for hours without displaying anything. If I comment out the contents of the <magelia> element in the web.config file, I get the null reference error I mention above. Is there a relationship between the two phenomena?
Coordinator
Mar 14, 2013 at 4:20 PM
Hi,


The startersite relies on services provided by the Magelia WebStore Administration Console, so you have to install one instance somewhere (IIS or WebMatrix) :

If you don't want to install things on IIS you have two solution :
Cyril DURAND