install magelia

Jul 3, 2013 at 12:36 PM
Bonjour,

Quand j'essaie d'installer Magelia sur mon PC, il veut installer SQL SERVER EXPRESS sauf que j'aimerais installer avec mon Server SQL R2.
Auriez-vous un tutoriel expliquant la procédure à suivre ?

merci d'avance,

Mickael
Coordinator
Jul 3, 2013 at 4:30 PM
Edited Jul 3, 2013 at 4:32 PM
The question Mike adresses here is the following:
"When I try to install Magelia Webstore, Web Platform Installer wants to install SQL Server Express but I would like to use the SQL Server R2 that is already installed"

Here is the solution that Aloys from our R&D team came up with :

First you have to know that WebPI has its own logic and Magelia WebStore setup process is independent from Web Platform Installer. So, even if you install Magelia WebStore using WebPI and install a SQL Server Database, during Magelia WebStore setup process, you would still be able to use your SQL Server R2 instance.

But the best solution, as you suggest, is to apply the following procedure and that way, you wil not have to install SQL Server Express

In Web Platform Installer, go to « Options », and check « Click to enable remote database support » indicate the name of the existing DB:

Image

Then click install and web PI will ask which database to use and you will be able to indicate your DB with the password for the sa account

Image

This will enable you NOT TO install SQL Server Express


During the installation proess, Magelia Serup will ask you again for this information. This is due to the fact that Magelia WebStore is independant from Magelia WebStore.

Image

Please confirm that it solved the problem.
Best regards
Jul 4, 2013 at 7:47 AM
bonjour,

J'ai essayé de faire la méthode proposée mais je n'ai pas le lien "Option" ni d'onglet prérequis.

Voici une capture d'écran de ce que j'ai dans IIS quand j'installe Magelia.
Image


Cordialement,

Mickael
Coordinator
Jul 4, 2013 at 8:21 AM
Hi Mickael,
In you reply, you say that you do not see the 'options' link but it is visible on the screen capture that you sent, in the background window, next to the "Installer" button.
Could you please try that link.
If if does not work, could you check that you use Web PI 4.5 or upgrade to WebPI 4.5.
Best regards,
Yves-Alain
Jul 4, 2013 at 9:29 AM
Merci beaucoup.
J'ai réussi à changer le mot de passe du compte SA et il a réussi a se connecter.

Merci pour la rapidité de vos réponses.
Coordinator
Jul 4, 2013 at 9:43 AM
Your Welcome, please do not hesitate if you need further assistance.
Once you will have installed Magelia WebStore, If you have a few seconds, please rate and review Magelia WebStore (in english please) by clicking on "review this release" from the following page: https://mageliawebstore.codeplex.com/releases/view/102986.

For information., Magelia WebStore v2.4 is in final testing stage and, after version 2.4 is relased, a free responsive design e-commerce template will be released later this month.

Best regards,

Yves-Alain
Jul 4, 2013 at 12:16 PM
J'ai encore un petit problème.

j'ai fais l'installation puis à la fin il m'a demander de me créer un compte ce que j'ai fais voici ce que j'ai eu.
Image

dès que j'ai fais valider (créer un compte)

j'ai eu cette erreur
Image


Faut -il changer quelque chose dans la configuration ?

J'ai suivi ce guide : http://www.magelia.org/resources/guides/installation-guide#Installation%20of%20WebPI
Jul 4, 2013 at 2:42 PM
Hi Mike,

Apparently your server is not able to reach our authentication web services during the setup.

We have made several tests on our platform and each one indicates that authentication web services are working correctly.

Please ensure that the server on which you try to install Magelia WebStore has an active internet connection and is not located behind a firewall which might block requests between our web services and your server.

If your server configuration seems to be correct, I invite you to try to create your account again.

Regards,
GAUTHEY Aloys
Jul 4, 2013 at 3:38 PM
Le serveur sur lequel je veux installer est mon local (ordinateur personnel)

J'ai désactiver l'antivirus et relancer l'installation mais j'ai toujours la meme erreur.
J'ai bien une connexion internet


Cordialement,

Mickael LEBLANC
Coordinator
Jul 4, 2013 at 4:39 PM
Hi Mickael,
At this stage we do not clearly understand if the problem you have comes from your environment or from Magelia setup procedure.
We tried to reproduce the problem in three different configurations this afternoon but Magelia WebStore setup was a success in all three cases.
In order to be able to investigate the problem further could you please send us your e-mail using the magelia webstore contact us form http://www.magelia.org/contact.
We will then contact you and investigate the problem directly with you tomorrow.
Best regards,
Yves-Alain
Jul 5, 2013 at 7:19 AM
Bonjour,

Ok merci beaucoup pour toutes vos réponses rapide.
Je vais regarder sur le projet en local.

Cordialement,

Mickael LEBLANC