Magelia 2.4 services are not up, why does ping fails?

Dec 22, 2013 at 7:50 AM
Edited Dec 22, 2013 at 8:25 AM
I am facing problem in configuring Magelia store services. The goal is to integrate with orchard, however I do not get true when using ping http://localhost:82/store/services/Administration/Heartbeat.svc/ping
Server Error in '/store/Services' Application
 Could not load file or assembly 'Magelia.WebStore.Runtime.Web' or one of its dependencies.
Although, I am able to navigate to admin panel properly.

I get same error when I try to obtain metadata using browser.
I also tried using localhost services url as input to magelia responsive visual studio template => Nothing was fetched.

I have installed Magelia.WebStore.2.4.331.6 binaries. Here are the steps I have followed-
  • Importing deployment package into IIS, new website running IIS4.5 App pool http://localhost:82/store
  • For SQL setup I had selected auto attach db, on .\SQLEXPRESS
  • Selected option to install default products & default users (undeletable)
  • Browse to Default.aspx located in root folder
  • Completed registration process
What mistake I have made?
Coordinator
Dec 23, 2013 at 9:52 AM
Hi,

Thanks for trying Magelia WebStore.

I think the problem is that WCF Activation for HTTP is not enabled. You could enable it using the "add roles and features" or by using the following command line
DISM /online /enable-feature /featurename:WCF-HTTP-Activation
Let us know if you have any other problem.

Best regards,

Cyril DURAND
Marked as answer by autrevo on 12/24/2013 at 8:37 AM
Dec 24, 2013 at 9:06 AM
Edited Dec 24, 2013 at 4:37 PM
Thankyou. I could fix the issue by enabling WCF-HTTP activation.
Could you refer some reference, where I could see list of such commands?